Description
The Welcart e-Commerce WordPress plugin before 2.12.6 does not properly sanitise and escape a parameter before using it in a SQL query, and strips the escaping it had applied before running the query, allowing users with the Editor role or higher to perform SQL injection attacks.
Published:
2026-10-28
Score:
n/a
EPSS:
n/a
KEV:
No
Analysis and contextual insights are available on OpenCVE Cloud.
Remediation
No solution or workaround provided in the CVE record.
Additional remediation guidance may be available on OpenCVE Cloud.
Tracking
Sign in to view the affected projects.
Advisories
No advisories yet.
References
History
Wed, 28 Oct 2026 06:15:00 +0000
| Type | Values Removed | Values Added |
|---|---|---|
| Description | The Welcart e-Commerce WordPress plugin before 2.12.6 does not properly sanitise and escape a parameter before using it in a SQL query, and strips the escaping it had applied before running the query, allowing users with the Editor role or higher to perform SQL injection attacks. | |
| Title | Welcart e-Commerce < 2.12.6 - Editor+ SQLi via 'log_id' Parameter | |
| References |
|
Subscriptions
No data.
Status: PUBLISHED
Assigner: WPScan
Published:
Updated: 2026-10-28T06:00:24.314Z
Reserved: 2026-10-15T12:07:07.665Z
Link: CVE-2026-111027
No data.
Status : Received
Published: 2026-10-28T06:16:34.190
Modified: 2026-10-28T06:16:34.190
Link: CVE-2026-111027
No data.
OpenCVE Enrichment
No data.
Weaknesses
No weakness.